summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-24 14:44:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-24 14:52:32 +0300
commit2fea2b641457eafc934b854e74386389e36123ce (patch)
tree4bb2f4ef8088628fa152f470dacb77259caadf2b
parent1597613488d328c7987a18c088cf6e47467223b9 (diff)
downloadpatches-2fea2b641457eafc934b854e74386389e36123ce.tar
patches-2fea2b641457eafc934b854e74386389e36123ce.tar.gz
gnu: java-eclipse-jetty-test-helper: Don't use unstable tarball.
* gnu/packages/web.scm (java-eclipse-jetty-test-helper)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/web.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0092477679..16e2832a62 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6264,12 +6264,14 @@ technologies.")
(name "java-eclipse-jetty-test-helper")
(version "4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/eclipse/jetty.toolchain/"
- "archive/jetty-test-helper-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/jetty.toolchain/")
+ (commit (string-append "jetty-test-helper-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1jd6r9wc26fa11si4rn2gvy8ml8q4zw1nr6v04mjp8wvwpgvzwx5"))))
+ "1g7cdh03nfwbdxzvwm84ysgvw08xx7431lsjryj2gmf3lrqpizgb"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "eclipse-jetty-test-helper.jar"