summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-23 15:03:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-23 15:04:12 +0200
commitcf4a56d748c5768c39c792ab4c87cd529ebec1a8 (patch)
tree4db44e93d05d528a643b721ebc7402461d97d28e
parente84d9dcd5b80fbacc2853bde53cf0e2da572beb5 (diff)
downloadpatches-cf4a56d748c5768c39c792ab4c87cd529ebec1a8.tar
patches-cf4a56d748c5768c39c792ab4c87cd529ebec1a8.tar.gz
gnu: Add texlive-marginnote.
* gnu/packages/tex.scm (texlive-marginnote): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cd461314b5..3e67c75c6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -7169,6 +7169,32 @@ a different path and manipulating characters. It includes the functionality
of the old package @code{pst-char}.")
(license license:lppl))))
+(define-public texlive-marginnote
+ (let ((template (simple-texlive-package
+ "texlive-marginnote"
+ (list "/source/latex/marginnote/marginnote.dtx")
+ (base32
+ "1vj1k8xm11gjdfj60as42d8lsv3dbzrm5dlgqcfk89d9dzm3k39j"))))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/marginnote")
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/marginnote")
+ ((#:build-targets _ '())
+ ''("marginnote.dtx"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/marginnote") #t))))))
+ (synopsis "Notes in the margin")
+ (description "This package provides the command @code{\\marginnote} that
+may be used instead of @code{\\marginpar} at almost every place where
+@code{\\marginpar} cannot be used, e.g., inside floats, footnotes, or in
+frames made with the @code{framed} package.")
+ (license license:lppl1.3c+))))
+
(define-public texlive-iftex
(let ((template (simple-texlive-package
"texlive-iftex"