summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-04-21 16:56:42 -0500
committerRicardo Wurmus <rekado@elephly.net>2020-04-23 07:08:07 +0200
commitc47f48d972cd13ee2cdf86d075f34fa0e944a764 (patch)
treefea50cecde7c01c5155cdc096cf8115c9039cb73
parent179c59c3d3a7c446f0c0e4b55f799ad3a2abc48c (diff)
downloadpatches-c47f48d972cd13ee2cdf86d075f34fa0e944a764.tar
patches-c47f48d972cd13ee2cdf86d075f34fa0e944a764.tar.gz
gnu: Add visidata.
* gnu/packages/visidata.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/visidata.scm64
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4af79f0caf..a6e1ed2d37 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -32,6 +32,7 @@
# Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
# Copyright © 2020 Michael Rohleder <mike@rohleder.de>
# Copyright © 2020 Felix Gruber <felgru@posteo.net>
+# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
#
# This file is part of GNU Guix.
#
@@ -522,6 +523,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/video.scm \
%D%/packages/vim.scm \
%D%/packages/virtualization.scm \
+ %D%/packages/visidata.scm \
%D%/packages/vnc.scm \
%D%/packages/vpn.scm \
%D%/packages/vulkan.scm \
diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
new file mode 100644
index 0000000000..68ea401362
--- /dev/null
+++ b/gnu/packages/visidata.scm
@@ -0,0 +1,64 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages visidata)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages python-science)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages time)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public visidata
+ (package
+ (name "visidata")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "visidata" version))
+ (sha256
+ (base32
+ "10adfyn4gkisvciqawgh2lakkhhnjjxiyp7mzbgcwkq1b3sigpf1"))))
+ (build-system python-build-system)
+ ;; Tests disabled because they are not packaged with the source tarball.
+ ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
+ (arguments '(#:tests? #f))
+ (inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-fonttools" ,python-fonttools)
+ ("python-h5py" ,python-h5py)
+ ("python-lxml" ,python-lxml)
+ ("python-openpyxl" ,python-openpyxl)
+ ("python-pandas" ,python-pandas)
+ ("python-psycopg2" ,python-psycopg2)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-xlrd" ,python-xlrd)))
+ (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
+ (description
+ "VisiData is an interactive multitool for tabular data. It combines the
+clarity of a spreadsheet, the efficiency of the terminal, and the power of
+Python, into a lightweight utility which can handle millions of rows.")
+ (home-page "https://www.visidata.org/")
+ (license (list license:gpl3
+ license:expat)))) ;; visidata/vdtui.py