summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 14:31:09 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:26 -0500
commitbbf9845f4ff6d59164758a7f2a5b2294e99fc0c6 (patch)
treea1f6255bf1c56afbb20c17573d5d5062b5a4790d
parent59e98d754a3cdf37bb8b045fdfba51f62d42444f (diff)
downloadpatches-bbf9845f4ff6d59164758a7f2a5b2294e99fc0c6.tar
patches-bbf9845f4ff6d59164758a7f2a5b2294e99fc0c6.tar.gz
gnu: ghc-libmpd: Update to 0.9.0.10.
* gnu/packages/haskell-xyz.scm (ghc-libmpd): Update to 0.9.0.10. [inputs]: Add 'ghc-safe-exceptions'.
-rw-r--r--gnu/packages/haskell-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3bf5630969..a32cc94c80 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5712,7 +5712,7 @@ to be called from Haskell.")
(define-public ghc-libmpd
(package
(name "ghc-libmpd")
- (version "0.9.0.9")
+ (version "0.9.0.10")
(source
(origin
(method url-fetch)
@@ -5722,7 +5722,7 @@ to be called from Haskell.")
".tar.gz"))
(sha256
(base32
- "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ "0vy287mn1vk8kvij5i3hc0p02l886cpsq5dds7kl6g520si3abkb"))))
(build-system haskell-build-system)
;; Tests fail on i686.
;; See https://github.com/vimus/libmpd-haskell/issues/112
@@ -5732,6 +5732,7 @@ to be called from Haskell.")
("ghc-old-locale" ,ghc-old-locale)
("ghc-data-default-class" ,ghc-data-default-class)
("ghc-network" ,ghc-network)
+ ("ghc-safe-exceptions" ,ghc-safe-exceptions)
("ghc-utf8-string" ,ghc-utf8-string)))
(native-inputs
`(("ghc-quickcheck" ,ghc-quickcheck)