summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-04-08 17:30:45 +0100
committerLudovic Courtès <ludo@gnu.org>2020-04-23 23:59:23 +0200
commitb90b7f16edea92e3554c4563d376292f5fb525cb (patch)
treeb90f94fba782cfb5a0088a3baed1357a262009b8
parent59be2959a652e6eaf22be5808009e1cd1400e043 (diff)
downloadpatches-b90b7f16edea92e3554c4563d376292f5fb525cb.tar
patches-b90b7f16edea92e3554c4563d376292f5fb525cb.tar.gz
gnu: Add wolf-spectrum.
* gnu/packages/music.scm (wolf-spectrum): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/music.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1e44fe23d5..34d4adb33c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5480,3 +5480,26 @@ plugin and a standalone JACK application.")
It is provided as an LV2 plugin and as a standalone Jack application.")
(home-page "https://pdesaulniers.github.io/wolf-shaper/")
(license license:gpl3)))
+
+(define-public wolf-spectrum
+ (package
+ (inherit wolf-shaper)
+ (name "wolf-spectrum")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdesaulniers/wolf-spectrum")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17db1jlj7vb1xyvkdhhrsvdbwb7jqw6i4168cdvlj3yvn2ra8gpm"))))
+ (synopsis "2D spectrogram plugin")
+ (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+ (home-page "https://github.com/pdesaulniers/wolf-spectrum")
+ (license license:gpl3)))