summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-04 06:17:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-11 13:46:40 +0200
commit6d53111385b804b7eb7e4f414dc1c02d30848515 (patch)
treef38ca15bf923ef52e799c5c1ada781713a32cd3a
parentf89cc6bdf96dca08d68a53b8332fd1829004cfaa (diff)
downloadpatches-6d53111385b804b7eb7e4f414dc1c02d30848515.tar
patches-6d53111385b804b7eb7e4f414dc1c02d30848515.tar.gz
gnu: Add emacs-evil-expat.
* gnu/packages/emacs-xyz.scm (emacs-evil-expat): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e8035a3f08..ece6a8a1b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5759,6 +5759,33 @@ surrounding lines.")
aligning text objects based on separators.")
(license license:gpl3+))))
+(define-public emacs-evil-expat
+ (let ((commit "4c344ea19b789002d759a202ffbf594730d2c59a")
+ (version "0.0.1")
+ (revision "1"))
+ (package
+ (name "emacs-evil-expat")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edkolev/evil-expat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16v7fnldxag6l1lsnrnhdjkga9qi78lbdfbb82k6pmv04991mbkr"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)))
+ (home-page "https://github.com/edkolev/evil-expat")
+ (synopsis "Extra @code{ex} commands for @code{evil-mode}")
+ (description
+ "This package provides additional commands for the @code{ex} command
+line, including functions for version control with Git and for copying and
+pasting into and from @code{tmux} paste buffers.")
+ (license license:gpl3+))))
+
(define-public emacs-monroe
(package
(name "emacs-monroe")