summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-22 23:47:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-22 23:47:59 +0200
commit541ec4d6e80110a640eefa4e1041bb83f4f12421 (patch)
tree94f1e9c7e70b54608831c9e559c06a823efd8feb
parentf91ad0b13d8d3d5b1ae92e209b1be6e8473385ba (diff)
downloadpatches-541ec4d6e80110a640eefa4e1041bb83f4f12421.tar
patches-541ec4d6e80110a640eefa4e1041bb83f4f12421.tar.gz
gnu: Add emacs-xclip.
* gnu/packages/emacs-xyz.scm (emacs-xclip): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32b1868813..5130cfdfad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20263,6 +20263,29 @@ commands in @code{evil-mode}.")
Emacs windows and tmux panes.")
(license license:expat)))
+(define-public emacs-xclip
+ (package
+ (name "emacs-xclip")
+ (version "1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "xclip-" version ".el"))
+ (sha256
+ (base32 "0i3i9kwfg8qmhcmqhhnrb1kljgwkccv63s9q1mjwqfjldyfh8j8i"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/xclip.html")
+ (synopsis "Copy and paste GUI clipboard from Emacs in text terminal")
+ (description
+ "This package allows Emacs to copy to and paste from the GUI clipboard
+when running in text terminal.
+
+It can use external command-line tools for that, e.g., @command{xclip} or
+@command{xsel}, which you may need to install in order for the package to
+work.")
+ (license license:gpl3+)))
+
(define-public emacs-xterm-color
(package
(name "emacs-xterm-color")