summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-23 01:12:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-23 01:12:41 +0200
commit179c59c3d3a7c446f0c0e4b55f799ad3a2abc48c (patch)
tree75425a0d205104e047f629bc80e06d38b5b2b27c
parent50d31a40f1a458b41f0ee59f5f5cb0d3837bf90a (diff)
downloadpatches-179c59c3d3a7c446f0c0e4b55f799ad3a2abc48c.tar
patches-179c59c3d3a7c446f0c0e4b55f799ad3a2abc48c.tar.gz
gnu: Add pyzo.
* gnu/packages/python-xyz.scm (pyzo): New variable.
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 457e5e6bea..1a7bbcc299 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19506,3 +19506,41 @@ randomly picked from wordlists. It supports several sources of
randomness (including real life dice) and different wordlists (including
cryptographically signed ones).")
(license license:gpl3+)))
+
+(define-public pyzo
+ (package
+ (name "pyzo")
+ (version "4.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyzo" version))
+ (sha256
+ (base32 "1zplxcb78qy8qibifmnsx5i9gnlfmw9n6nr4yflsabpxw57mx4m1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-home-directory
+ (lambda _
+ ;; Tests fail with "Permission denied: '/homeless-shelter'".
+ (setenv "HOME" "/tmp")
+ #t)))
+ ;; Tests fail with "Uncaught Python exception: invalid literal for
+ ;; int() with base 10: 'test'".
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-pyqt" ,python-pyqt)))
+ (home-page "https://pyzo.org")
+ (synopsis
+ "Python IDE for scientific computing")
+ (description
+ "Pyzo is a Python IDE focused on interactivity and introspection,
+which makes it very suitable for scientific computing. Its practical
+design is aimed at simplicity and efficiency.
+
+It consists of two main components, the editor and the shell, and uses
+a set of pluggable tools to help the programmer in various ways. Some
+example tools are source structure, project manager, interactive help,
+workspace...")
+ (license license:bsd-2)))