summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-05-16 20:11:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-05-20 15:19:48 +0200
commita5948c0d41d7850c93f3128461ad3e87089e52a3 (patch)
treee7097616c958d56027e18ffcb72dc36806cea54f
parent8b196ad208e844e2829e49382811dff327bd297d (diff)
downloadpatches-a5948c0d41d7850c93f3128461ad3e87089e52a3.tar
patches-a5948c0d41d7850c93f3128461ad3e87089e52a3.tar.gz
gnu: Add gcc-objc++-4.9.
* gnu/packages/gcc.scm (gcc-objc++-4.9): New variable.
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index d8b96c7dd0..53b6c54ec9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -635,6 +635,15 @@ as the 'native-search-paths' field."
(variable "LIBRARY_PATH")
(files '("lib" "lib64"))))))
+(define-public gcc-objc++-4.9
+ (custom-gcc gcc-4.9 "gcc-objc++" '("obj-c++")
+ (list (search-path-specification
+ (variable "OBJCPLUS_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64"))))))
+
(define (make-libstdc++-doc gcc)
"Return a package with the libstdc++ documentation for GCC."
(package