summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-22 15:43:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-22 15:44:30 +0200
commitcbd2e1edc82b1ad6aec57ac9cac9a837790715e4 (patch)
tree8a7b845929d9d76b843fda04375f152244c2a785
parentdecf7f6c418f681cfaeb3d94c37ac3d135057f6e (diff)
downloadpatches-cbd2e1edc82b1ad6aec57ac9cac9a837790715e4.tar
patches-cbd2e1edc82b1ad6aec57ac9cac9a837790715e4.tar.gz
gnu: Remove mumimu.
* gnu/packages/mail.scm (mumimu): Remove variable.
-rw-r--r--gnu/packages/mail.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f4a2def7e9..b6c566f8cb 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -796,53 +796,6 @@ messages you need; in addition, it allows you to view messages, extract
attachments, create new maildirs, and so on.")
(license gpl3+)))
-(define mumimu
- ;; This is a fork of mu for use in Mumi that stores message bug IDs in its
- ;; database. It also renames the library to "mumimu" to avoid confusion.
- (let ((commit "6b42431052c7cc9a2e147938e1b67f14a93e4ee5")
- (revision "2"))
- (package
- (inherit mu)
- (name "mumimu")
- (version (git-version (package-version mu) revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.elephly.net/software/mumimu.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "044scxmjrckidqx935yza3aqnjyzrmhyvgx2gs2jyf68hl2qzb89"))))
- (arguments
- (substitute-keyword-arguments (package-arguments mu)
- ((#:tests? anything '())
- #f)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'patch-configure
- (lambda _ (delete-file "autogen.sh") #t))
- (replace 'fix-ffi
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "guile/mumimu.scm"
- (("\"libguile-mu\"")
- (format #f "\"~a/lib/libguile-mumimu\""
- (assoc-ref outputs "out"))))
- #t))
- (delete 'install-emacs-autoloads)))
- ((#:configure-flags flags)
- '("--disable-gtk"
- "--disable-webkit"
- "--disable-mu4e"))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("glib" ,glib "bin")
- ("tzdata" ,tzdata-for-tests)
- ("texinfo" ,texinfo))))))
-
(define-public alot
(package
(name "alot")