summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-22 11:02:43 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-22 11:02:43 +0200
commit618819aa2feed5b8e7dfdceebb0987ca6453e98a (patch)
tree7536d32665d41d86b74778b010c81881f9a23e9d
parented248424d87e8df28583aa820569669db83a80be (diff)
downloadpatches-618819aa2feed5b8e7dfdceebb0987ca6453e98a.tar
patches-618819aa2feed5b8e7dfdceebb0987ca6453e98a.tar.gz
gnu: Add w-scan.base-for-series-3625
* gnu/packages/video.scm (w-scan): New variable.
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 85c195a383..8d64cbade7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3920,3 +3921,31 @@ work-in-progress, aiming to support video-on-demand and live streaming
applications. It only supports Intel-compatible CPUs (x86).")
(home-page "https://github.com/OpenVisualCloud/SVT-AV1")
(license license:bsd-2)))
+
+(define-public w-scan
+ (package
+ (name "w-scan")
+ (version "20170107")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.gen2vdr.de/wirbel/w_scan/w_scan-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1zkgnj2sfvckix360wwk1v5s43g69snm45m0drnzyv7hgf5g7q1q"))))
+ (build-system gnu-build-system)
+ (synopsis "Scan ATSC/DVB-C/DVB-S/DVB-T channels")
+ (description
+ "This is a small command line utility used to perform frequency scans for
+DVB and ATSC transmissions without initial tuning data. It can print the
+result in several formats:
+@itemize
+@item VDR channels.conf,
+@item czap/tzap/xine/mplayer channels.conf,
+@item Gstreamer dvbsrc plugin,
+@item VLC xspf playlist,
+@item XML,
+@item initial tuning data for scan or dvbv5-scan.
+@end itemize\n")
+ (home-page "https://www.gen2vdr.de/wirbel/w_scan/index2.html")
+ (license license:gpl2+)))