summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-21 12:38:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-21 12:38:19 +0300
commit5d29808beaa0e68f33504c3a3bf6373b36dcabfa (patch)
treea0296947f7345dee42ada73cb7e6f170cc7427f7
parent5327b399a875a00304ccc1e6ece7190f26113539 (diff)
downloadpatches-5d29808beaa0e68f33504c3a3bf6373b36dcabfa.tar
patches-5d29808beaa0e68f33504c3a3bf6373b36dcabfa.tar.gz
gnu: rdf.scm: Use license: prefix.
* gnu/packages/rdf.scm: Use a 'license:' prefix for package licenses instead of only importing a select number of licenses.
-rw-r--r--gnu/packages/rdf.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index d255815e85..2c773af0bb 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -21,8 +21,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages rdf)
- #:use-module ((guix licenses)
- #:select (non-copyleft asl2.0 isc gpl2 lgpl2.1 lgpl2.1+ lgpl3+))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix download)
@@ -85,7 +84,7 @@ of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
HTML and JSON.")
- (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
+ (license license:lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
(define-public clucene
(package
@@ -119,7 +118,7 @@ HTML and JSON.")
(description "CLucene is a high-performance, scalable, cross platform,
full-featured indexing and searching API. It is a port of the very popular
Java Lucene text search engine API to C++.")
- (license lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public lucene++
(package
@@ -150,7 +149,7 @@ Java Lucene text search engine API to C++.")
(synopsis "Text search engine")
(description "Lucene++ is an up to date C++ port of the popular Java
Lucene library, a high-performance, full-featured text search engine.")
- (license (list asl2.0 lgpl3+)))); either asl or lgpl.
+ (license (list license:asl2.0 license:lgpl3+)))); either asl or lgpl.
(define-public lrdf
(package
@@ -195,7 +194,7 @@ Lucene library, a high-performance, full-featured text search engine.")
LADSPA plugins. It can also be used for general RDF manipulation. It can
read RDF/XLM and N3 files and export N3 files, and it also has a light
taxonomic inference capability.")
- (license gpl2)))
+ (license license:gpl2)))
(define-public rasqal
(package
@@ -236,7 +235,7 @@ SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental
SPARQL extensions (LAQRS). Rasqal can write binding query results in the
SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and
Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
- (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
+ (license license:lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
(define-public redland
(package
@@ -261,7 +260,7 @@ Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
(synopsis "RDF library")
(description "The Redland RDF Library (librdf) provides the RDF API
and triple stores.")
- (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
+ (license license:lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
(define-public serd
(package
@@ -295,7 +294,7 @@ knife of RDF syntax, but rather is suited to resource limited or performance
critical applications (e.g. converting many gigabytes of NTriples to Turtle),
or situations where a simple reader/writer with minimal dependencies is
ideal (e.g. in LV2 implementations or embedded applications).")
- (license isc)))
+ (license license:isc)))
(define-public sord
(package
@@ -330,7 +329,7 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(synopsis "C library for storing RDF data in memory")
(description
"Sord is a lightweight C library for storing RDF data in memory.")
- (license isc)))
+ (license license:isc)))
(define-public python-rdflib
(package
@@ -365,8 +364,8 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(description
"RDFLib is a Python library for working with RDF, a simple yet
powerful language for representing information.")
- (license (non-copyleft "file://LICENSE"
- "See LICENSE in the distribution."))))
+ (license (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))
(define-public python2-rdflib
(package-with-python2 python-rdflib))