summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-14 19:25:55 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-14 19:25:55 +0100
commit092e86f54f5be0481fbe7bd42432e34fe6d7b1df (patch)
tree7005694ce54ece8d840a16e925b4613d77c9a176
parentbec07a7c083406b6691cd8162ab020e27d908b5c (diff)
downloadpatches-092e86f54f5be0481fbe7bd42432e34fe6d7b1df.tar
patches-092e86f54f5be0481fbe7bd42432e34fe6d7b1df.tar.gz
gnu: Add python2-cssutils.
* gnu/packages/python.scm (python2-cssutils): New variable.
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 697c832aac..bd2e497c0d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3105,3 +3105,42 @@ capabilities to the Python interpreter.")
(license (x11-style
"file://README"
"See 'README' in the distribution."))))
+
+(define-public python2-cssutils
+ (package
+ (name "python2-cssutils")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/c/cssutils/cssutils-"
+ version
+ ".zip"))
+ (sha256
+ (base32
+ "1bwim1353r4hqiir73sn4sc43y7ymh09qx0kly7vj048blppc125"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python2-mock" ,python2-mock) ; for the tests
+ ("unzip" ,unzip))) ; for unpacking the source
+ (inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (arguments
+ `(#:python ,python-2 ; Otherwise tests fail with a syntax error.
+ #:tests? #f ; The tests apparently download an external URL.
+ #:phases
+ (alist-replace
+ 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (and (zero? (system* "unzip" source))
+ (chdir "cssutils-1.0")))
+ %standard-phases)))
+ (home-page "http://cthedot.de/cssutils/")
+ (synopsis
+ "CSS Cascading Style Sheets library for Python")
+ (description
+ "Cssutils is a Python package for parsing and building CSS
+Cascading Style Sheets. Currently it provides a DOM only and no rendering
+options.")
+ (license lgpl3+)))