summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-12 12:00:08 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:57 -0500
commiteb81114cd2a23f5a7ef25905d904c6f0b0e2b67f (patch)
treebdde372064356c84c0947ebc065fe7a43cde7154
parentdd34630f56f546204ecae768a9ec7705da9d213d (diff)
downloadpatches-eb81114cd2a23f5a7ef25905d904c6f0b0e2b67f.tar
patches-eb81114cd2a23f5a7ef25905d904c6f0b0e2b67f.tar.gz
gnu: Add aliased.
* gnu/packages/perl.scm (perl-aliased): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fc8deccc19..81c8a0d235 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -103,6 +103,27 @@ program. It is guaranteed to find the *smallest possible* set of
differences.")
(license (package-license perl))))
+(define-public perl-aliased
+ (package
+ (name "perl-aliased")
+ (version "0.34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+ "aliased-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1syyqzy462501kn5ma9gl6xbmcahqcn4qpafhsmpz0nd0x2m4l63"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/aliased")
+ (synopsis "Use shorter versions of class names")
+ (description "The alias module loads the class you specify and exports
+into your namespace a subroutine that returns the class name. You can
+explicitly alias the class to another name or, if you prefer, you can do so
+implicitly.")
+ (license (package-license perl))))
+
(define-public perl-archive-zip
(package
(name "perl-archive-zip")