summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-04-12 10:43:11 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-19 11:10:06 +0200
commit541dac8aee0834668e9b305fc526d41530e8bd58 (patch)
tree4e0c32b54f1604bb5bb9f959afd51730f79438df
parent3ebf2c2947e60353cc63eb3d5cb8d1fa015b6332 (diff)
downloadpatches-541dac8aee0834668e9b305fc526d41530e8bd58.tar
patches-541dac8aee0834668e9b305fc526d41530e8bd58.tar.gz
gnu: Add spindle.
* gnu/packages/admin.scm (spindle): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/admin.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c88f44a3f5..5b47d5faec 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2567,3 +2567,33 @@ launch daemons into the relevant nodes.")
(home-page "https://github.com/LLNL/LaunchMON")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:lgpl2.1)))
+
+(define-public spindle
+ (package
+ (name "spindle")
+ (version "0.10")
+ (source (origin
+ ;; We use git checkout to avoid github auto-generated tarballs
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hpc/Spindle.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15n3ay0qq81r5v7fif61q1vdjcq44pp2nynkh3fvbzc9fj3c39wd"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("--enable-sec-launchmon"
+ "--enable-sec-munge"
+ "--enable-sec-none")))
+ (inputs
+ `(("mpi" ,openmpi)
+ ("munge" ,munge)
+ ("launchmon" ,launchmon)
+ ("libgcrypt" ,libgcrypt)))
+ (synopsis "Scalable library loading in HPC environments")
+ (description
+ "Spindle is a tool for improving the performance of dynamic library and
+Python loading in HPC environments.")
+ (home-page "https://github.com/hpc/Spindle")
+ (license license:lgpl2.1)))