summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:06:06 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:09 +0200
commit52485163f3ccb65e46f9ae1929aa380e6abfd3aa (patch)
tree5f70f28c57ea6553b2db19aa051ced01f8a33773
parentde3108835cc137fdf1c44313bbd331f2e1b4fae4 (diff)
downloadpatches-52485163f3ccb65e46f9ae1929aa380e6abfd3aa.tar
patches-52485163f3ccb65e46f9ae1929aa380e6abfd3aa.tar.gz
gnu: Add ocaml-core-kernel.
* gnu/packages/ocaml.scm (ocaml-core-kernel): New variable.
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 863e367a5b..b7adc6e560 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2907,3 +2907,35 @@ the expected output.")
(synopsis "Standard Jane Street ppx rewriters")
(description "Ppx_jane is a ppx_driver including all standard ppx rewriters.")
(license license:asl2.0)))
+
+(define-public ocaml-core-kernel
+ (package
+ (name "ocaml-core-kernel")
+ (version "113.33.03")
+ (source (janestreet-origin "core_kernel" version
+ "0fl23jrwivixawhxinbwaw9cabqnzn7fini7dxpxjjvkxdc8ip5y"))
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("bin_prot" ,ocaml-bin-prot)
+ ("ppx-assert" ,ocaml-ppx-assert)
+ ("ppx-bench" ,ocaml-ppx-bench)
+ ("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-expect" ,ocaml-ppx-expect)
+ ("ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("typerep" ,ocaml-typerep)
+ ("sexplib" ,ocaml-sexplib)
+ ("variantslib" ,ocaml-variantslib)
+ ("result" ,ocaml-result)
+ ("fieldslib" ,ocaml-fieldslib)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/core_kernel/")
+ (synopsis "Portable standard library for OCaml")
+ (description "Core is an alternative to the OCaml standard library.
+
+Core_kernel is the system-independent part of Core. It is aimed for cases when
+the full Core is not available, such as in Javascript.")
+ (license license:asl2.0)))