summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-04-09 22:03:30 +0200
committerClément Lassieur <clement@lassieur.org>2018-04-19 00:13:04 +0200
commit28ca6b35d9b5ed89c4ec65f50b80e3b320e4354d (patch)
tree0677ffa320a0167571b4c1aa9634130344ad12ce
parente8360eb8ea015cf35ae67d8071e38d7f9276667f (diff)
downloadpatches-28ca6b35d9b5ed89c4ec65f50b80e3b320e4354d.tar
patches-28ca6b35d9b5ed89c4ec65f50b80e3b320e4354d.tar.gz
gnu: Add emacs-lispyville.
* gnu/packages/emacs.scm (emacs-lispyville): New variable.
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index dde9589a58..a26fbd122f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3593,6 +3593,35 @@ S-expression editing when point is at the beginning or end of an
S-expression.")
(license license:gpl3+))))
+(define-public emacs-lispyville
+ ;; Later versions need a more recent Evil, with an evil-define-key*
+ ;; supporting nil for the state.
+ (let ((commit "b4291857ed6a49a67c4ea77522889ce51fb171ab")
+ (revision "0"))
+ (package
+ (name "emacs-lispyville")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/noctuid/lispyville")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "095zibzc3naknahdrnb59g9rbljy8wz9rkc7rf8avb3wxlwvxhm3"))
+ (file-name (git-file-name name version))))
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)
+ ("emacs-lispy" ,emacs-lispy)))
+ (build-system emacs-build-system)
+ (synopsis "Minor mode for integrating Evil with lispy")
+ (description
+ "LispyVille's main purpose is to provide a Lisp editing environment
+suited towards Evil users. It can serve as a minimal layer on top of lispy
+for better integration with Evil, but it does not require the use of lispy’s
+keybinding style. The provided commands allow for editing Lisp in normal
+state and will work even without lispy being enabled.")
+ (license license:gpl3+))))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")