summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-29 21:18:53 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-29 21:18:53 +0200
commit0a5a1db2d4b4607acba03df4164d8f839acf0dd8 (patch)
tree96fc93f6b6a23bd5a974719d145d07963f747e01
parent29a2ccd3841e4f82957e29b0adb34f1da8bfbd23 (diff)
downloadpatches-0a5a1db2d4b4607acba03df4164d8f839acf0dd8.tar
patches-0a5a1db2d4b4607acba03df4164d8f839acf0dd8.tar.gz
gnu: git: Do not retain reference from "out" to Subversion.
* gnu/packages/version-control.scm (git): Wrap 'git-svn', not 'git', for PERL5LIB and LD_LIBRARY_PATH.
-rw-r--r--gnu/packages/version-control.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index e0287fd1a1..a7333c0ce7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -125,16 +125,7 @@ from a command line or use a GUI application.")
(wrap-program git-svn*
`("PATH" ":" prefix
(,(string-append (assoc-ref inputs "subversion")
- "/bin"))))
-
- ;; Tell 'git' to look for core programs in the user's profile.
- ;; This allows user to install other outputs of this package and
- ;; have them transparently taken into account. There's a
- ;; 'GIT_EXEC_PATH' environment variable, but it's supposed to
- ;; specify a single directory, not a search path.
- (wrap-program (string-append out "/bin/git")
- `("PATH" ":" prefix
- ("$HOME/.guix-profile/libexec/git-core"))
+ "/bin")))
`("PERL5LIB" ":" prefix
(,(string-append (assoc-ref inputs "subversion")
"/lib/perl5/site_perl")))
@@ -143,7 +134,16 @@ from a command line or use a GUI application.")
;; help it find 'libsvn_client-1.so'.
`("LD_LIBRARY_PATH" ":" prefix
(,(string-append (assoc-ref inputs "subversion")
- "/lib"))))))
+ "/lib"))))
+
+ ;; Tell 'git' to look for core programs in the user's profile.
+ ;; This allows user to install other outputs of this package and
+ ;; have them transparently taken into account. There's a
+ ;; 'GIT_EXEC_PATH' environment variable, but it's supposed to
+ ;; specify a single directory, not a search path.
+ (wrap-program (string-append out "/bin/git")
+ `("PATH" ":" prefix
+ ("$HOME/.guix-profile/libexec/git-core")))))
%standard-phases))))
(synopsis "Distributed version control system")
(description