summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene <pacoon@protonmail.com>2018-04-14 12:19:52 -0500
committerMarius Bakke <mbakke@fastmail.com>2018-04-17 00:29:00 +0200
commit08fda9c6c0e15c223225e780e8aa1dc5a8546ee7 (patch)
tree8a6c40d1e5405592802297c14f6b80c338c2053a
parentd09e31bdf66b12c9756aede3b306909a9b0235f4 (diff)
downloadpatches-08fda9c6c0e15c223225e780e8aa1dc5a8546ee7.tar
patches-08fda9c6c0e15c223225e780e8aa1dc5a8546ee7.tar.gz
gnu: xpad: Update to 5.0.0.
* gnu/packages/gnome.scm (xpad) Update to 5.0.0. [arguments]: Add autogen phase. [native-inputs]: Add autoconf and automake. [inputs]: Remove gtk+. [native-inputs]: Add gtk+:bin. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43ea75a1d4..9145f62a8b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6661,22 +6661,31 @@ is suitable as a default application in a Desktop environment.")
(define-public xpad
(package
(name "xpad")
- (version "4.8.0")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/xpad/trunk/4.8.0/+download/"
+ (uri (string-append "https://launchpad.net/xpad/trunk/"
+ version "/+download/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "17f915yyvfa2fsavq6wh0q0dfhib28b4k1gc0292b9xdlrvy7f22"))))
+ "02yikxg6z9bwla09ka001ppjlpbv5kbza3za9asazm5aiz376mkb"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'run-autogen
+ (lambda _
+ (system* "sh" "autogen.sh"))))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("gtk+" ,gtk+)
- ("gtksourceview" ,gtksourceview)
+ `(("gtksourceview" ,gtksourceview)
("libsm" ,libsm)))
(home-page "https://wiki.gnome.org/Apps/Xpad")
(synopsis "Virtual sticky note")