summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-09-20 00:15:41 +0200
committerBrian Leung <leungbk@mailfence.com>2019-09-20 02:20:54 +0200
commit923e561e6a4b6dc0e34e26fded93ae97a9a9f712 (patch)
treea25f481aae148a69519d6e390cde026919e2fd61
parent81b8a1a98641ad68277ffcb59e4750fb2a9f0ffc (diff)
downloadpatches-923e561e6a4b6dc0e34e26fded93ae97a9a9f712.tar
patches-923e561e6a4b6dc0e34e26fded93ae97a9a9f712.tar.gz
gnu: emacs-iedit: Update to 0.9.9.9-1.e2c100c.
* gnu/packages/emacs-xyz.scm (emacs-iedit): Update to 0.9.9.9-1.e2c100c.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9a252a0e3c..f8f897649f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5184,30 +5184,33 @@ highlighted. Pressing that character will switch to that window.")
(license license:gpl3+)))
(define-public emacs-iedit
- (package
- (name "emacs-iedit")
- (version "0.9.9.9")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/victorhge/iedit.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1pwkrm98vlpzsy5iwwfksdaz3zzyi7bvdf5fglhsn4ssf47p787g"))))
- (build-system emacs-build-system)
- (home-page "http://www.emacswiki.org/emacs/Iedit")
- (synopsis "Edit multiple regions in the same way simultaneously")
- (description
- "This package is an Emacs minor mode and allows you to edit one
+ ;; Last release version was in 2016.
+ (let ((commit "e2c100cdd67b7d82835d281ac2cd1bf4f374bc8f")
+ (revision "1"))
+ (package
+ (name "emacs-iedit")
+ (version (git-version "0.9.9.9" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/victorhge/iedit.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wr3w2id95wx2rma8n1ifjrv9rx37ly26ijc5zi58id0yrip3hnc"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.emacswiki.org/emacs/Iedit")
+ (synopsis "Edit multiple regions in the same way simultaneously")
+ (description
+ "This package is an Emacs minor mode and allows you to edit one
occurrence of some text in a buffer (possibly narrowed) or region, and
simultaneously have other occurrences edited in the same way.
You can also use Iedit mode as a quick way to temporarily show only the buffer
lines that match the current text being edited. This gives you the effect of
a temporary @code{keep-lines} or @code{occur}.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-zoutline
(package