summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-15 23:55:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-19 01:19:33 +0100
commitd296d30013587722b37aeb0be114e00b15564f3f (patch)
treeb087fe5d3bb38e07eb38457fa23f06215831d7a9
parentfffcd8b829d1fbd8bdb6af85385033224c576cec (diff)
downloadpatches-d296d30013587722b37aeb0be114e00b15564f3f.tar
patches-d296d30013587722b37aeb0be114e00b15564f3f.tar.gz
gnu: python-flask-wtf: Drop failing test.
* gnu/packages/python.scm (python-flask-wtf, python2-flask-wtf)[arguments]: Add phase to delete file that needs network access.
-rw-r--r--gnu/packages/python.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 70aa8cd665..635feb489c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9922,6 +9922,16 @@ presume or force a developer to use a particular tool or library.")
(base32
"04l5743j2dici46038sqlzvf0xzpg8rf7s9ld2x24xv7f4idg990"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'drop-failing-test
+ (lambda _
+ ;; FIXME: This file tries resolving an external server, which
+ ;; fails. Try to patch out the offending section instead of
+ ;; deleting the whole thing.
+ (delete-file "tests/test_recaptcha.py")
+ #t)))))
(propagated-inputs
`(("python-flask-babel" ,python-flask-babel)
("python-babel" ,python-babel)