summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 21:15:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 23:30:23 +0200
commit987232e67d9fa77eb1e636e94cb576bf579a0923 (patch)
treefa799c8529ce9dac845c45b6fe0e0676af0e7923
parent8dca3bde0e4c3624273b242c5f251ad045f3f28a (diff)
downloadpatches-987232e67d9fa77eb1e636e94cb576bf579a0923.tar
patches-987232e67d9fa77eb1e636e94cb576bf579a0923.tar.gz
gnu: Add perl-data-record.
* gnu/packages/perl.scm (perl-data-record): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1cc3582f42..8f5a5c50b6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1738,6 +1738,33 @@ The maths behind this is unfortunately fiddly, hence this module.")
formatted (to be inspected by a human).")
(license (package-license perl))))
+(define-public perl-data-record
+ (package
+ (name "perl-data-record")
+ (version "0.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/O/OV/OVID/"
+ "Data-Record-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gwyhjwg4lrnfsn8wb6r8msb4yh0y4wca4mz3z120xbnl9nycshx"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)
+ ("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-sub-uplevel" ,perl-sub-uplevel)))
+ (home-page "http://search.cpan.org/dist/Data-Record/")
+ (synopsis "Conditionally split data into records")
+ (description "This Perl module allows you to split data into records by
+not only specifying what you wish to split the data on, but also by specifying
+an \"unless\" regular expression. If the text in question matches the
+\"unless\" regex, it will not be split there. This allows us to do things
+like split on newlines unless newlines are embedded in quotes.")
+ (license (package-license perl))))
+
(define-public perl-data-stag
(package
(name "perl-data-stag")