summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-04-14 13:24:10 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-04-14 13:24:10 -0400
commit85c7e8e611be1bdc2eed47e61e9ff45d92ab293d (patch)
tree5b8791208db7b95db8b1478c64f2578733fe6d66
parente6f0ca2f0598e6b0278aeecacfc88c925011c547 (diff)
downloadpatches-85c7e8e611be1bdc2eed47e61e9ff45d92ab293d.tar
patches-85c7e8e611be1bdc2eed47e61e9ff45d92ab293d.tar.gz
Revert "gnu: util-linux: Add "static" output."
This reverts commit df887432be25e1534b9ecdccf39c98857b1d0786.
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8659471623..310bb57127 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -463,11 +463,12 @@ providing the system administrator with some help in common tasks.")
(("build_kill=yes") "build_kill=no"))
#t))))
(build-system gnu-build-system)
- (outputs '("out"
- "static")) ; >2 MiB of static .a libraries
(arguments
`(#:configure-flags (list "--disable-use-tty-group"
+ ;; Do not build .a files to save 2 MiB.
+ "--disable-static"
+
;; Install completions where our
;; bash-completion package expects them.
(string-append "--with-bashcompletiondir="
@@ -492,19 +493,6 @@ providing the system administrator with some help in common tasks.")
(substitute* "tests/ts/misc/mcookie"
(("/etc/services")
(string-append net "/etc/services")))
- #t)))
- (add-after
- 'install 'move-static-libraries
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (static (assoc-ref outputs "static")))
- (mkdir-p (string-append static "/lib"))
- (with-directory-excursion out
- (for-each (lambda (file)
- (rename-file file
- (string-append static "/"
- file)))
- (find-files "lib" "\\.a$")))
#t))))))
(inputs `(("zlib" ,zlib)
("ncurses" ,ncurses)))