summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 15:59:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 13:22:10 +0100
commit58a35665d98386d98e7fbb84812d2b2282990eca (patch)
tree14b65dbfdc4c5b210451787ffc37461f413ed3fc
parent14386fc7d9192b35a81dedb7616a44651807ee19 (diff)
downloadpatches-58a35665d98386d98e7fbb84812d2b2282990eca.tar
patches-58a35665d98386d98e7fbb84812d2b2282990eca.tar.gz
gnu: Add python-mpmath.
* gnu/packages/python.scm (python-mpmath, python2-mpmath): New variables.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7e7e54f54f..0414e889fe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5406,6 +5406,36 @@ and statistical routines from scipy and statsmodels.")
(propagated-inputs `(("python2-pytz" ,python2-pytz)
,@(package-propagated-inputs base))))))
+(define-public python-mpmath
+ (package
+ (name "python-mpmath")
+ (version "0.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://mpmath.org/files/mpmath-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08ijsr4ifrqv3cjc26mkw0dbvyygsa99in376hr4b96ddm1gdpb8"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero?
+ (system* "python" "mpmath/tests/runtests.py" "-local")))))))
+ (home-page "http://mpmath.org")
+ (synopsis "Arbitrary-precision floating-point arithmetic in python")
+ (description
+ "@code{mpmath} can be used as an arbitrary-precision substitute for
+Python's float/complex types and math/cmath modules, but also does much
+more advanced mathematics.")
+ (license license:bsd-3)))
+
+(define-public python2-mpmath
+ (package-with-python2 python-mpmath))
+
(define-public python-sympy
(package
(name "python-sympy")