summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-10-24 18:21:16 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-10-25 16:24:03 +0200
commit4c77abc4dad1dde19124391355015ffd10ff43df (patch)
tree0d2bd671ef45953b035e41efec8ec912748515a3
parent6a23c8b183371678d61c5a324b2922564d505212 (diff)
downloadpatches-4c77abc4dad1dde19124391355015ffd10ff43df.tar
patches-4c77abc4dad1dde19124391355015ffd10ff43df.tar.gz
gnu: Add r-forcats.
* gnu/packages/statistics.scm (r-forcats): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b3ebd5abbd..96b390185a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
+;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5442,3 +5443,27 @@ the least concave majorant (LCM), for the half-normal and correlation
distributions, and for computing empirical higher criticism (HC) scores and
the corresponding decision threshold.")
(license license:gpl3+)))
+
+(define-public r-forcats
+ (package
+ (name "r-forcats")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "forcats" version))
+ (sha256
+ (base32
+ "1mvwkynvvgz2vi8dyz11x7xrp53kadjawjcja34hwk1d89qf7g5m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-magrittr" ,r-magrittr)
+ ("r-tibble" ,r-tibble)))
+ (home-page "http://forcats.tidyverse.org")
+ (synopsis "Tools for working with factors")
+ (description "This package provides helpers for reordering factor
+levels (including moving specified levels to front, ordering by first
+appearance, reversing, and randomly shuffling), and tools for modifying factor
+levels (including collapsing rare levels into other, \"anonymizing\", and
+manually \"recoding\").")
+ (license license:gpl3)))