summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-09-27 21:42:16 -0400
committerChristopher Baines <mail@cbaines.net>2017-10-01 11:56:50 +0100
commit0ef1c223071869488c35b72b7407234c11425589 (patch)
tree679e1b95c00327b5413bc579063e0e66d7b44e37
parent32e23abae01d1261519578252fca2d44394afe26 (diff)
downloadpatches-0ef1c223071869488c35b72b7407234c11425589.tar
patches-0ef1c223071869488c35b72b7407234c11425589.tar.gz
gnu: Add emacs-writeroom.
* gnu/packages/emacs.scm (emacs-writeroom): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6576a9f04d..5d1090fb7e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3574,6 +3574,31 @@ wrapping lines at the window edge, which is the standard behaviour of
window edge.")
(license license:gpl3+)))
+(define-public emacs-writeroom
+ (package
+ (name "emacs-writeroom")
+ (version "3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/joostkremers/writeroom-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0yqgp5h3kvvpgva4azakb2wnjl7gsyh45glf75crspv3xyq57f2r"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-visual-fill-column" ,emacs-visual-fill-column)))
+ (home-page "https://github.com/joostkremers/writeroom-mode")
+ (synopsis "Distraction-free writing for Emacs")
+ (description
+ "This package defines a minor mode for distraction-free writing. Some of
+the default effects include entering fullscreen, deleting other windows of the
+current frame, disabling the mode line, and adding margins to the buffer that
+restrict the text width to 80 characters.")
+ (license license:bsd-3)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")