summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-21 21:36:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-21 21:36:12 +0300
commit09cbd53c5fd871cf5ac1d7f80a5ed1c70b615340 (patch)
treed7ed792783fde734607c9d6d2f043eddb1f261e6
parenta0adbb046382d0575abaf285a7d9c928ee478fe3 (diff)
downloadpatches-09cbd53c5fd871cf5ac1d7f80a5ed1c70b615340.tar
patches-09cbd53c5fd871cf5ac1d7f80a5ed1c70b615340.tar.gz
gnu: libarchive: Update to 3.2.1.
* gnu/packages/backup.scm (libarchive): Update to 3.2.1. [arguments]: Build with '-std=C99'.
-rw-r--r--gnu/packages/backup.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index a0ff535dfe..eb36238b44 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -136,7 +136,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
- (version "3.2.0")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
@@ -144,7 +144,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
version ".tar.gz"))
(sha256
(base32
- "11xabdpmvdmcdkidigmqh4ymhra95lr7ipcys4hdq0gzf7ylbkkv"))))
+ "1lngng84k1kkljl74q0cdqc3s82vn2kimfm02dgm4d6m7x71mvkj"))))
(build-system gnu-build-system)
;; TODO: Add -L/path/to/nettle in libarchive.pc.
(inputs
@@ -175,7 +175,10 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(zero? (system* "./libarchive_test" "^test_*_disk*"))
(zero? (system* "./bsdcpio_test" "^test_owner_parse"))
(zero? (system* "./bsdtar_test"))))
- %standard-phases))))
+ %standard-phases))
+ ;; libarchive/test/test_write_format_gnutar_filenames.c needs to be
+ ;; compiled with C99 or C11 or a gnu variant.
+ #:configure-flags '("CFLAGS=-O2 -g -std=c99")))
(home-page "http://libarchive.org/")
(synopsis "Multi-format archive and compression library")
(description