summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:54:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:26 +0200
commit098cb1e9c4548ccd78405141b32b6ec6d556c4b6 (patch)
tree9d72fa1c8af1ea41f962f42679da6656e70e4d4f
parent7cd51cd28e401fc610ad49e3d0d3c8da1598d111 (diff)
downloadpatches-098cb1e9c4548ccd78405141b32b6ec6d556c4b6.tar
patches-098cb1e9c4548ccd78405141b32b6ec6d556c4b6.tar.gz
gnu: Add python-cytoolz.
* gnu/packages/python.scm (python-cytoolz): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index eff28a9102..b6665ce3b5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14089,3 +14089,30 @@ library's @code{threading} module.")
"This package provides a set of utility functions for iterators,
functions, and dictionaries.")
(license license:bsd-3)))
+
+(define-public python-cytoolz
+ (package
+ (name "python-cytoolz")
+ (version "0.9.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cytoolz" version))
+ (sha256
+ (base32
+ "1r80p88hm3f3r4zpixzr047y5hw4bzy41m4xywnhycda83x0dk44"))))
+ (build-system python-build-system)
+ ;; FIXME: tests fail with "module 'cytoolz.curried' has no attribute
+ ;; 'exceptions'"
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-toolz" ,python-toolz)))
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (home-page "https://github.com/pytoolz/cytoolz")
+ (synopsis "High performance functional utilities")
+ (description
+ "The cytoolz package implements the same API as provided by toolz. The
+main differences are that @code{cytoolz} is faster and cytoolz offers a C API
+that is accessible to other projects developed in Cython.")
+ (license license:bsd-3)))