summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-12 01:13:32 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-12-13 09:37:49 +0100
commitd660f7be6d0fee9922076cd953194a60e3852255 (patch)
tree701dc92c5b88888a43885ba0b9e8b461eb0fdf5a
parentad04bd6b2a3274222a5a618fd8d7927ea0bf1b1c (diff)
downloadpatches-d660f7be6d0fee9922076cd953194a60e3852255.tar
patches-d660f7be6d0fee9922076cd953194a60e3852255.tar.gz
gnu: python-setuptools: Update to 31.0.0.
* gnu/packages/python.scm (python-setuptools, python2-setuptools): Update to 31.0.0. [source]: Use 'pypi-uri'. [license]: Update for bundled libraries.
-rw-r--r--gnu/packages/python.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 35ccf7bf6f..6d6d880bb8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -819,15 +819,14 @@ have been used.")
(define-public python-setuptools
(package
(name "python-setuptools")
- (version "18.3.1")
+ (version "31.0.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/s/setuptools/setuptools-"
- version ".tar.gz"))
+ (uri (pypi-uri "setuptools" version))
(sha256
(base32
- "0kc7rbav00ks6iaw14p38y81q12fx0lpkhgf5m97xc04f5r318ig"))
+ "0ypybh4hx3bv4vhg2dc74xpj1g56ggnaffm87k4abhwjwq6wq608"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -853,7 +852,12 @@ test hooks,
project installation,
platform-specific details,
Python 3 support.")
- (license license:psfl)))
+ ;; TODO: setuptools now bundles the following libraries:
+ ;; packaging, pyparsing, six and appdirs. How to unbundle?
+ (license (list license:psfl ; setuptools itself
+ license:expat ; six, appdirs, pyparsing
+ license:asl2.0 ; packaging is dual ASL2/BSD-2
+ license:bsd-2))))
(define-public python2-setuptools
(package-with-python2 python-setuptools))