summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-07-06 19:02:13 +0200
committerRoel Janssen <roel@gnu.org>2016-07-06 19:02:13 +0200
commit8f82641ac97a126c799d4b807db9fb4a056f8227 (patch)
tree17c6fc32a02c9cf0ef25905d7b7166dfb4294007
parent41184943ae77bdc097f375be5b946800b9825d64 (diff)
downloadpatches-8f82641ac97a126c799d4b807db9fb4a056f8227.tar
patches-8f82641ac97a126c799d4b807db9fb4a056f8227.tar.gz
gnu: Add emacs-hl-todo.
* gnu/packages/emacs.scm (emacs-hl-todo): New variable.
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 78557e4693..12414bd963 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1766,6 +1766,28 @@ features found in other packages it also brings many improvements as
well as completely new features.")
(license license:gpl3+)))
+(define-public emacs-hl-todo
+ (package
+ (name "emacs-hl-todo")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/tarsius/hl-todo/"
+ version "/hl-todo.el"))
+ (sha256
+ (base32
+ "18zydm43zajlglhgr0bhdkd4pln27amd063k2ql6p1mvyam3j8ia"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tarsius/hl-todo")
+ (synopsis "Emacs mode to highlight TODO and similar keywords")
+ (description
+ "This package provides an Emacs mode to highlight TODO and similar
+keywords in comments and strings. This package also provides commands for
+moving to the next or previous keyword and to invoke @code{occur} with a
+regexp that matches all known keywords.")
+ (license license:gpl3+)))
+
(define-public emacs-hydra
(package
(name "emacs-hydra")