summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-17 15:48:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-17 15:53:03 +0200
commitd3f292b8dcd205728231d2bee669a0f8d76fd8e6 (patch)
treed32d1dba90ea00ccb9a1ddb3ae49dc8b34baa0e8
parent79ef0726a9afb7bd4676b9a53401f742c7b83653 (diff)
downloadpatches-d3f292b8dcd205728231d2bee669a0f8d76fd8e6.tar
patches-d3f292b8dcd205728231d2bee669a0f8d76fd8e6.tar.gz
gnu: python-tables: Update to 3.6.1.
* gnu/packages/python-xyz.scm (python-tables): Update to 3.6.1. [arguments]: Adjust use-gcc phase.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c54bfc417..ce4a0d29a8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7980,14 +7980,14 @@ printing of sub-tables by specifying a row range.")
(define-public python-tables
(package
(name "python-tables")
- (version "3.4.4")
+ (version "3.6.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tables" version))
(sha256
(base32
- "0affz7k8babh8wdmsgrz5jxrd569by2w8ffimcxs9wiaf5rw1idx"))
+ "0j8vnxh2m5n0cyk9z3ndcj5n1zj5rdxgc1gb78bqlyn2lyw75aa9"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -8005,9 +8005,11 @@ printing of sub-tables by specifying a row range.")
(add-after 'unpack 'use-gcc
(lambda _
(substitute* "setup.py"
- (("compiler = new_compiler\\(\\)" line)
+ (("^( +)compiler = new_compiler\\(\\)" line indent)
(string-append line
- "\ncompiler.set_executables(compiler='gcc',"
+ "\n"
+ indent
+ "compiler.set_executables(compiler='gcc',"
"compiler_so='gcc',"
"linker_exe='gcc',"
"linker_so='gcc -shared')")))