summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-17 10:40:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-17 10:40:34 +0300
commitb9dd2a2fb7dda8b2b9686e8e4bf5cca19514a08d (patch)
tree3cfd19b3cc83794c96c1ca00221331d78b8013aa
parent2cc226bbc758f815ae1d58ad77ea58a7174cef2a (diff)
downloadpatches-b9dd2a2fb7dda8b2b9686e8e4bf5cca19514a08d.tar
patches-b9dd2a2fb7dda8b2b9686e8e4bf5cca19514a08d.tar.gz
gnu: khal: Fix build with python-urwid-2.1.0.
* gnu/packages/calendar.scm (khal)[source]: Download upstream patch to fix compatibility with newer python-urwid.
-rw-r--r--gnu/packages/calendar.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index bd47800d1d..291221bc26 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -180,7 +180,17 @@ data units.")
(uri (pypi-uri "khal" version))
(sha256
(base32
- "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))))
+ "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))
+ (patches
+ (list
+ (origin
+ (method url-fetch)
+ ;; This patch fixes an issue with python-urwid-2.1.0
+ (uri "https://github.com/pimutils/khal/commit/2c5990c2de2015b251ba23617faa40ee11b8c22a.patch")
+ (file-name "khal-compat-urwid-2.1.0.patch")
+ (sha256
+ (base32
+ "11nd8hkjz68imwqqn0p54zmb53z2pfxmzchaviy7jc1ky5s9l663")))))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases