summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-04-15 18:41:07 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-17 13:03:02 +0200
commit79ef0726a9afb7bd4676b9a53401f742c7b83653 (patch)
tree2ddc4ec8c23da1eda7598f876a56d88e871e2da4
parent5ea902874bff728770a46002be4b3a749d1ee8db (diff)
downloadpatches-79ef0726a9afb7bd4676b9a53401f742c7b83653.tar
patches-79ef0726a9afb7bd4676b9a53401f742c7b83653.tar.gz
gnu: python-podcastparser: Run tests.
* gnu/packages/gpodder.scm (python-podcastparser)[native-inputs]: Add python-coverage. [arguments]: Replace 'check phase and invoke "nosetests". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gpodder.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 98d7a84ce7..6963da9dff 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -184,7 +184,13 @@ downloading episode status changes.")
(sha256
(base32 "0k62ppg20i41gcc5x8ddjn7zbpy47hqpxzrq9257g2c71m4qw07b"))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "nosetests"))))))
(build-system python-build-system)
(home-page "http://gpodder.org/podcastparser")
(synopsis "Simplified and fast RSS parser Python library")