summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-04-16 12:28:16 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-04-16 20:46:38 -0700
commit2d9886f7e8838d6aeb0cfb20a2a49fc7d8fb233c (patch)
treeb81be5bb731207e1f3bd0713fb196925a056360e
parentcdac010c1936f5d909d4b7f74961fa41ad754f3e (diff)
downloadpatches-2d9886f7e8838d6aeb0cfb20a2a49fc7d8fb233c.tar
patches-2d9886f7e8838d6aeb0cfb20a2a49fc7d8fb233c.tar.gz
gnu: diffoscope: Update to 141.
* gnu/packages/diffoscope (diffoscope): Update to 141. [arguments]: Add phase add-known-tools. [native-inputs]: Add hdf5.
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 37f8f74b7b..f9a7c66646 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -68,7 +68,7 @@
#:use-module (ice-9 match))
(define-public diffoscope
- (let ((version "139"))
+ (let ((version "141"))
(package
(name "diffoscope")
(version version)
@@ -80,7 +80,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1k4yjyvmn5nfdapkwgkr9gzpn18kr4c58n0f32pfkx4yakfqkk4i"))))
+ "0pls2jryx394ysaz0g8h959lhrsdqak9bkxjd5r6sdckgiikplkj"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -91,6 +91,12 @@
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
+ ;; Patch in support for known tools
+ (add-after 'unpack 'add-known-tools
+ (lambda _
+ (substitute* "diffoscope/external_tools.py"
+ (("'debian': 'hdf5-tools'")
+ "'debian': 'hdf5-tools', 'guix': 'hdf5'"))))
;; This test is broken because our `file` package has a
;; bug in berkeley-db file type detection.
(add-after 'unpack 'remove-berkeley-test
@@ -189,6 +195,7 @@
("giflib:bin" ,giflib "bin")
("gnumeric" ,gnumeric)
("gnupg" ,gnupg)
+ ("hdf5" ,hdf5)
("imagemagick" ,imagemagick)
("libarchive" ,libarchive)
("llvm" ,llvm)