summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-16 22:36:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-16 22:40:40 +0300
commitbe02a4cb81887c1d15ad04c22fe5a9351578c2aa (patch)
treefd93befe85b0e34686b5089da94c7d4e3c04473a
parent626874eb3f0e02e5a4e2a6277c69bce9b25c6484 (diff)
downloadpatches-be02a4cb81887c1d15ad04c22fe5a9351578c2aa.tar
patches-be02a4cb81887c1d15ad04c22fe5a9351578c2aa.tar.gz
gnu: python-hy: Update to 0.18.0.
* gnu/packages/python-xyz.scm (python-hy): Update to 0.18.0. [arguments]: Make all phases return #t. [propagated-inputs]: Remove python-clint, python-fastentrypoints. Add python-colorama. (python2-hy): Remove variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1e72dbca7b..e3ec0010ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9447,20 +9447,20 @@ with a new public API, and RPython support.")
(define-public python-hy
(package
(name "python-hy")
- (version "0.17.0")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "hy" version))
(sha256
(base32
- "1gdbqsirsdxj320wnp7my5awzs1kfs6m4fqmkzbd1zd47qzj0zfi"))))
+ "04dfwm336gw61fmgwikvh0cnxk682p19b4w555wl5d7mlym4rwj2"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'install 'set-HOME
- (lambda _
- (setenv "HOME" "/tmp")))
+ (add-before 'install 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp") #t))
(replace 'check
(lambda _
;; Tests require write access to HOME.
@@ -9471,10 +9471,8 @@ with a new public API, and RPython support.")
("python-nose" ,python-nose)))
(propagated-inputs
`(("python-astor" ,python-astor)
- ("python-clint" ,python-clint)
+ ("python-colorama" ,python-colorama)
("python-rply" ,python-rply)
- ("python-fastentrypoints"
- ,python-fastentrypoints)
("python-funcparserlib"
,python-funcparserlib)))
(home-page "http://hylang.org/")
@@ -9485,9 +9483,6 @@ its Lisp code into the Python Abstract Syntax Tree, you have the whole world of
Python at your fingertips, in Lisp form.")
(license license:expat)))
-(define-public python2-hy
- (package-with-python2 python-hy))
-
(define-public python2-functools32
(package
(name "python2-functools32")