summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-27 21:59:22 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-28 00:07:28 +0200
commitbd51224936f3f1146800f48e5827baeb00ec30fd (patch)
tree6d200836abc94133bbfcfaa7232f5e82a3a411a9
parent657175446257f8f8d16fd3464da9d95dce8a95f4 (diff)
downloadpatches-bd51224936f3f1146800f48e5827baeb00ec30fd.tar
patches-bd51224936f3f1146800f48e5827baeb00ec30fd.tar.gz
gnu: nss, nss-certs: Update to 3.32.
This release includes minor code changes and many certificate updates: <https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.32_release_notes> * gnu/packages/certs.scm (nss-certs): Update to 3.32. * gnu/packages/gnuzilla.scm (nss): Update to 3.32. [arguments]: Prevent another test file from being installed. * gnu/packages/patches/nss-pkgconfig.patch: Adjust.
-rw-r--r--gnu/packages/certs.scm4
-rw-r--r--gnu/packages/gnuzilla.scm5
-rw-r--r--gnu/packages/patches/nss-pkgconfig.patch4
3 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 2441de6631..c7242dea92 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -74,7 +74,7 @@
(define-public nss-certs
(package
(name "nss-certs")
- (version "3.31")
+ (version "3.32")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -85,7 +85,7 @@
"nss-" version ".tar.gz")))
(sha256
(base32
- "0pd643a8ns7q5az5ai3ascrw666i2kbfiyy1c9hlhw9jd8jn21g9"))))
+ "0dfkgvah0ji8b8lpxyy2w0b3lyz5ldmryii4z7j2bfwnrj0z7iim"))))
(build-system gnu-build-system)
(outputs '("out"))
(native-inputs
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 06b8d665fc..0fb25d8432 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -281,7 +281,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.31")
+ (version "3.32")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -292,7 +292,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "0pd643a8ns7q5az5ai3ascrw666i2kbfiyy1c9hlhw9jd8jn21g9"))
+ "0dfkgvah0ji8b8lpxyy2w0b3lyz5ldmryii4z7j2bfwnrj0z7iim"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
"nss-increase-test-timeout.patch"))))
@@ -364,6 +364,7 @@ in the Mozilla clients.")
;; phase to fail. Here we simply delete libgtest1.so, since it
;; seems to be used only during the tests.
(delete-file (string-append lib "/libgtest1.so"))
+ (delete-file (string-append lib "/libgtestutil.so"))
#t))))))
(inputs
diff --git a/gnu/packages/patches/nss-pkgconfig.patch b/gnu/packages/patches/nss-pkgconfig.patch
index a33e05fcf2..e3145aa4cf 100644
--- a/gnu/packages/patches/nss-pkgconfig.patch
+++ b/gnu/packages/patches/nss-pkgconfig.patch
@@ -221,5 +221,5 @@ Later adapted to apply cleanly to nss-3.21.
RELEASE = nss
--DIRS = coreconf lib cmd gtests
-+DIRS = coreconf lib cmd gtests config
+-DIRS = coreconf lib cmd cpputil gtests
++DIRS = coreconf lib cmd cpputil gtests config