summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-04 14:13:35 +0200
committerKei Kebreau <kkebreau@posteo.net>2019-06-20 23:24:40 -0400
commitb63c06f1d712b2cbd336a07621e9d28bdf803620 (patch)
treeea2d95211a5f8e3baa002eb38dbe3180298e0672
parentb468eedcb8da62587e33e5e3671dc4bd34cfaf34 (diff)
downloadpatches-b63c06f1d712b2cbd336a07621e9d28bdf803620.tar
patches-b63c06f1d712b2cbd336a07621e9d28bdf803620.tar.gz
gnu: evolution-data-server: Do not split outputs.
A binary in $out/libexec depends on libedataserverui libraries, so the split would require mutually recursive output dependencies. * gnu/packages/gnome.scm (evolution-data-server)[outputs]: Remove field. [arguments]: Remove "split" phase. (gnome-calendar, gnome-todo, evolution)[inputs]: Adjust.
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 4 insertions, 26 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8a30795bdd..8dc60daa92 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5137,7 +5137,6 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(sha256
(base32
"0h4f71kpf2ypdgifg369z35pk4cq99daw540yzjpax52grav2fjv"))))
- (outputs '("out" "libedataserverui"))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -5191,28 +5190,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
;; CMakeLists.txt hard-codes runpath to just the libdir.
;; Remove it so the configure flag is respected.
(("SET\\(CMAKE_INSTALL_RPATH .*") ""))
- #t))
- (add-after 'install 'split
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (libedsui (assoc-ref outputs "libedataserverui")))
- (for-each (lambda (file)
- (mkdir-p (dirname (string-append libedsui file)))
- (rename-file (string-append out file)
- (string-append libedsui file)))
- '("/lib/pkgconfig/libedataserverui-1.2.pc"
- "/lib/libedataserverui-1.2.so"
- "/lib/libedataserverui-1.2.so.2"
- "/lib/libedataserverui-1.2.so.2.0.0"
- "/lib/girepository-1.0/EDataServerUI-1.2.typelib"
- "/include/evolution-data-server/libedataserverui"
- "/share/gir-1.0/EDataServerUI-1.2.gir"
- "/share/vala/vapi/libedataserverui-1.2.vapi"
- "/share/vala/vapi/libedataserverui-1.2.deps"))
- (substitute* (string-append libedsui "/lib/pkgconfig/"
- "libedataserverui-1.2.pc")
- ((out) libedsui))
- #t))))))
+ #t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
@@ -6708,7 +6686,7 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("libdazzle" ,libdazzle)
- ("libedataserverui" ,evolution-data-server "libedataserverui")
+ ("libedataserverui" ,evolution-data-server)
("libgweather" ,libgweather)
("geoclue" ,geoclue)))
(home-page "https://wiki.gnome.org/Apps/Calendar")
@@ -6756,7 +6734,7 @@ desktop. It supports multiple calendars, month, week and year view.")
(inputs
`(("rest" ,rest) ; For Todoist plugin
("json-glib" ,json-glib) ; For Todoist plugin
- ("libedataserverui" ,evolution-data-server "libedataserverui")
+ ("libedataserverui" ,evolution-data-server)
("libical" ,libical)
("libpeas" ,libpeas)
("python-pygobject" ,python-pygobject)
@@ -8005,7 +7983,7 @@ generic enough to work for everyone.")
("gtkspell3" ,gtkspell3)
("highlight" ,highlight)
("libcanberra" ,libcanberra)
- ("libedataserverui" ,evolution-data-server "libedataserverui")
+ ("libedataserverui" ,evolution-data-server)
("libgweather" ,libgweather)
("libnotify" ,libnotify)
("libsoup" ,libsoup)