summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-04-17 02:34:11 +0200
committerGuix Patches Tester <>2020-04-17 01:38:07 +0100
commitb43c51c432dfac57a0269518166f45bb6c6f4c67 (patch)
treed8eab3d5773e8732d77a093d338a0c4bb8a5bfa2
parent145c9847b593f7d4c7b7dbaa10e4f4547135bf9d (diff)
downloadpatches-b43c51c432dfac57a0269518166f45bb6c6f4c67.tar
patches-b43c51c432dfac57a0269518166f45bb6c6f4c67.tar.gz
gnu: libupnp: Bump to 1.8.6; change the download method to git-fetch; add missing dependencies.
-rw-r--r--gnu/packages/upnp.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 8f3c887a68..be75b9068f 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages photo)
#:use-module (gnu packages image)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xiph)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages python)
@@ -92,15 +93,21 @@ over IRC, instant messaging, network games, and most server software.")
(define-public libupnp
(package
(name "libupnp")
- (version "1.6.25")
+ (version "1.8.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
- version "/" name "-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrjimenez/pupnp.git")
+ (commit (string-append "release-" version))))
(sha256
(base32
- "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
+ "1jlb6qh47513h2simy0zxia5q61w1c31mnwmjqpr2nf832lmnpk4"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(build-system gnu-build-system)
(arguments
;; The tests require a network device capable of multicasting which is