summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-04-17 02:34:08 +0200
committerGuix Patches Tester <>2020-04-17 01:38:06 +0100
commitab3561f43f684be2793e8afe189f46b0854477d5 (patch)
tree4c5eb9fc2f8ab6b711bea93b5592290cda41d8af
parentb9f4f27be2e2db37bfb0f1b824492e435754a682 (diff)
downloadpatches-ab3561f43f684be2793e8afe189f46b0854477d5.tar
patches-ab3561f43f684be2793e8afe189f46b0854477d5.tar.gz
gnu: pjproject-jami: Use the jami-apply-dependency-patches procedure.
-rw-r--r--gnu/packages/jami.scm60
1 files changed, 26 insertions, 34 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 27f6ff26f5..b165335e26 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -131,6 +131,8 @@
;; making a shared object;
"CFLAGS=-fPIC"
"CXXFLAGS=-fPIC")
+ #:modules ((guix build utils)
+ ,@(@@ (guix build-system gnu) %default-modules))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-git-checkout-writable
@@ -139,40 +141,30 @@
#t))
(add-after 'unpack 'apply-patches
(lambda* (#:key inputs #:allow-other-keys)
- (let ((savoir-faire-linux-patches-directory "Savoir-faire Linux patches")
- ;; Comes from
- ;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
- ;; WARNING: These amount for huge changes in pjproject.
- (savoir-faire-linux-patches
- '("fix_turn_alloc_failure"
- "rfc2466"
- "ipv6"
- "multiple_listeners"
- "pj_ice_sess"
- "fix_turn_fallback"
- "fix_ioqueue_ipv6_sendto"
- "add_dtls_transport"
- "rfc6544"
- "ice_config"
- "sip_config"
- "fix_first_packet_turn_tcp"
- "fix_ebusy_turn"
- "ignore_ipv6_on_transport_check"
- "fix_turn_connection_failure"
- ;; "uwp_vs" ; for windows
- "disable_local_resolution")))
- (mkdir-p savoir-faire-linux-patches-directory)
- (invoke "tar" "-xvf" (assoc-ref inputs "savoir-faire-linux-patches")
- "-C" savoir-faire-linux-patches-directory
- "--strip-components=5"
- "ring-project/daemon/contrib/src/pjproject")
- (for-each
- (lambda (file)
- (invoke "patch" "--force" "-p1" "-i"
- (string-append savoir-faire-linux-patches-directory "/"
- file ".patch")))
- savoir-faire-linux-patches))
- #t))
+ (let ((jami-apply-dependency-patches ,jami-apply-dependency-patches))
+ ;; Comes from
+ ;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
+ ;; WARNING: These amount for huge changes in pjproject.
+ (jami-apply-dependency-patches #:inputs inputs
+ #:dep-name "pjproject"
+ #:patches
+ '("fix_turn_alloc_failure"
+ "rfc2466"
+ "ipv6"
+ "multiple_listeners"
+ "pj_ice_sess"
+ "fix_turn_fallback"
+ "fix_ioqueue_ipv6_sendto"
+ "add_dtls_transport"
+ "rfc6544"
+ "ice_config"
+ "sip_config"
+ "fix_first_packet_turn_tcp"
+ "fix_ebusy_turn"
+ "ignore_ipv6_on_transport_check"
+ "fix_turn_connection_failure"
+ "disable_local_resolution"))
+ #t)))
;; TODO: We could use substitute-keyword-arguments instead of
;; repeating the phases from pjproject, but somehow it does
;; not work.