summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-08-19 02:18:08 -0400
committerMark H Weaver <mhw@netris.org>2018-08-19 02:19:20 -0400
commit860c37b9f21d8dd044ca44e6b60a8a29878abfd8 (patch)
tree28152bd65ab12c9ab240126b8b91c62b5549dba4
parent08e43eba4e62e3d6dd888fa97824ebeae0a64d1f (diff)
downloadpatches-860c37b9f21d8dd044ca44e6b60a8a29878abfd8.tar
patches-860c37b9f21d8dd044ca44e6b60a8a29878abfd8.tar.gz
gnu: linux-libre: Update to 4.18.3.
* gnu/packages/linux.scm (%linux-libre-version): Update to 4.18.3. (%linux-libre-hash): Update hash. (%linux-libre-patches): Rename to ... (%linux-libre-4.18-patches): ... this. (linux-libre, linux-libre-arm-generic, linux-libre-arm-omap2plus): Apply %linux-libre-4.18-patches.
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 19e68dcdcc..968beb52ee 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -404,10 +404,10 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.18.2")
-(define %linux-libre-hash "0kfbzwp56yf7lb884jcdwx5cia73k5ks3nzxb306lj4s249qkn17")
+(define %linux-libre-version "4.18.3")
+(define %linux-libre-hash "0z7nnkmk5d2npilviqxa0m6nn30f5arhviysby78kkb3j2isx9jx")
-(define %linux-libre-patches
+(define %linux-libre-4.18-patches
(list %boot-logo-patch
(origin
(method url-fetch)
@@ -432,7 +432,7 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-version
%linux-libre-hash
%linux-compatible-systems
- #:patches %linux-libre-patches
+ #:patches %linux-libre-4.18-patches
#:configuration-file kernel-config))
(define %linux-libre-4.14-version "4.14.65")
@@ -460,6 +460,7 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("armhf-linux")
+ #:patches %linux-libre-4.18-patches
#:defconfig "multi_v7_defconfig"
#:extra-version "arm-generic"))
@@ -474,6 +475,7 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-version
%linux-libre-hash
'("armhf-linux")
+ #:patches %linux-libre-4.18-patches
#:defconfig "omap2plus_defconfig"
#:extra-version "arm-omap2plus"))