summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-15 12:42:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-15 15:03:31 +0100
commit82924965d74cda9f23297b28f15feeda75867560 (patch)
treebf8aadce78274e0c0e06d4f40a43e6124e4b6eec
parentdf9f515ebca9bb3670a3d44c726c56744d85c099 (diff)
downloadpatches-82924965d74cda9f23297b28f15feeda75867560.tar
patches-82924965d74cda9f23297b28f15feeda75867560.tar.gz
gnu: rapidjson: Disable CPU optimization.
* gnu/packages/web.scm (rapidjson)[arguments]: Add #:configure-flags.
-rw-r--r--gnu/packages/web.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index bfc21c07a9..577be916bf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -775,7 +775,8 @@ current version of any major web browser.")
(substitute* (find-files "." "^CMakeLists\\.txt$")
(("native") "armv8-a"))
#t))))
- '()))
+ ;; Disable CPU optimization for reproducibility.
+ '(#:configure-flags '("-DRAPIDJSON_ENABLE_INSTRUMENTATION_OPT=OFF"))))
(home-page "https://github.com/Tencent/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description