summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:48 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commit6eda2635863d087a4cdacaea76ea5cadb8a2327c (patch)
treed4ce7f76333f1d211ceeff75b6b167b5ba7e083d
parent0119f17f5deb8886300e656f720a6e536759a542 (diff)
downloadpatches-6eda2635863d087a4cdacaea76ea5cadb8a2327c.tar
patches-6eda2635863d087a4cdacaea76ea5cadb8a2327c.tar.gz
gnu: Add ghc-network-info.
* gnu/packages/haskell.scm (ghc-network-info): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 839d9fc5d8..e3801d20b3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9756,4 +9756,26 @@ The implementation is made in C with a haskell FFI wrapper that hides
the C implementation.")
(license license:bsd-3)))
+(define-public ghc-network-info
+ (package
+ (name "ghc-network-info")
+ (version "0.2.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "network-info-" version "/"
+ "network-info-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xndvg776241fgjmynxfpy81f1csjmh8dg33yf0c8m71ychz3pzc"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/jystic/network-info")
+ (synopsis "Access the local computer's basic network configuration")
+ (description "This Haskell library provides simple read-only access to the
+local computer's networking configuration. It is currently capable of
+getting a list of all the network interfaces and their respective
+IPv4, IPv6 and MAC addresses.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here