summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-04-17 02:34:09 +0200
committerGuix Patches Tester <>2020-04-17 01:38:06 +0100
commit013abfb9567923cc0ea5dec45c118209771342cd (patch)
treed2c630aaa7916f0b49d4bfb8b194334f9b0d1312
parentab3561f43f684be2793e8afe189f46b0854477d5 (diff)
downloadpatches-013abfb9567923cc0ea5dec45c118209771342cd.tar
patches-013abfb9567923cc0ea5dec45c118209771342cd.tar.gz
gnu: Add libnatpmp.
-rw-r--r--gnu/packages/networking.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c97ac43dee..75084e5b86 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -374,6 +374,32 @@ between different versions of ØMQ.")
files contain direct mappings of the abstractions provided by the ØMQ C API.")
(license license:expat)))
+(define-public libnatpmp
+ (package
+ (name "libnatpmp")
+ (version "20150609")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://miniupnp.free.fr/files/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c1n8n7mp0amsd6vkz32n8zj3vnsckv308bb7na0dg0r8969rap1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (home-page "http://miniupnp.free.fr/libnatpmp.html")
+ (synopsis "C Library implementing NAT-PMP")
+ (description
+ "libnatpmp is a portable and asynchronous implementaiton of the NAT Port Mapping Protocol (NAT-PMP) written in C.")
+ (license license:bsd-3)))
+
(define-public librdkafka
(package
(name "librdkafka")