summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2016-11-16 01:14:36 +0100
committerLeo Famulari <leo@famulari.name>2016-11-18 15:05:59 -0500
commit01278f16a9bf93125376959b05d730ea02d9ff6c (patch)
treecac9f7034d8d3810a93c8ab7d5db50e4d6d1dc20
parentc2662820f359be19262cdd5d564e6a0dddc43281 (diff)
downloadpatches-01278f16a9bf93125376959b05d730ea02d9ff6c.tar
patches-01278f16a9bf93125376959b05d730ea02d9ff6c.tar.gz
gnu: Add xcalib.
* gnu/packages/xdisorg (xcalib): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/xdisorg.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 53048e0607..86f5ad203c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1070,3 +1071,43 @@ XCB util-xrm module provides the following libraries:
- xrm: utility functions for the X resource manager.")
(license license:x11)))
+
+(define-public xcalib
+ (package
+ (name "xcalib")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xcalib/xcalib/" version
+ "/xcalib-source-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rh6xb51c5xz926dnn82a2fn643g0sr4a8z66rn6yi7523kjw4ca"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("CC=gcc")
+ #:tests? #f ; No test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "xcalib" bin))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc (string-append(assoc-ref outputs "out")
+ "/share/doc/xcalib")))
+ (install-file "README" doc)
+ ;; Avoid unspecified return value.
+ #t))))))
+ (inputs `(("libx11", libx11)
+ ("libxext", libxext)
+ ("libxxf86vm", libxxf86vm)))
+ (synopsis "Tiny monitor calibration loader for XFree86 (or X.org)")
+ (description "xcalib is a tiny tool to load the content of vcgt-Tags in ICC
+profiles to the video card's gamma ramp. It does work with most video card
+drivers except the generic VESA driver. Alter brightness, contrast, RGB, and
+invert colors on a specific display/screen.")
+ (home-page "http://xcalib.sourceforge.net/")
+ (license license:gpl2)))