summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-15 23:13:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-16 07:07:23 +0200
commitfca68e34fb9b4f117eb2ce85d81053a8b07f142e (patch)
tree6d868027ef7ce27c41756f9519c81e9156c69ca9
parent229736aa523ec43821979b6aebbc7ccdb2fe0238 (diff)
downloadpatches-fca68e34fb9b4f117eb2ce85d81053a8b07f142e.tar
patches-fca68e34fb9b4f117eb2ce85d81053a8b07f142e.tar.gz
gnu: Add r-nbconvertr.
* gnu/packages/cran.scm (r-nbconvertr): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dd332cf4d4..3917545422 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21106,3 +21106,28 @@ client).")
designs with and without early outcomes for treatment selection and
subpopulation type designs.")
(license license:gpl3)))
+
+(define-public r-nbconvertr
+ (package
+ (name "r-nbconvertr")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nbconvertR" version))
+ (sha256
+ (base32
+ "0yhmz177r1miain65vspclahhz8cg7638ldbpsw8ylgf7a60l0sg"))))
+ (properties `((upstream-name . "nbconvertR")))
+ (build-system r-build-system)
+ (inputs
+ `(("jupyter" ,python-nbconvert)
+ ("pandoc" ,ghc-pandoc)))
+ (home-page "https://cran.r-project.org/web/packages/nbconvertR/")
+ (synopsis "Vignette engine wrapping Jupyter notebooks")
+ (description
+ "This package calls the Jupyter script @code{nbconvert} to create
+vignettes from notebooks. Those notebooks (@code{.ipynb} files) are files
+containing rich text, code, and its output. Code cells can be edited and
+evaluated interactively.")
+ (license license:gpl3)))