summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-14 13:54:53 -0700
committerBrian Leung <leungbk@mailfence.com>2019-10-14 14:08:40 -0700
commit36f6ed2c64f74193b45e343630d64b083b98b936 (patch)
tree61663ba9a1a3d8a492ca3abcfbe0c11acb1d1f3d
parent19e42618376e92cb9745197642ff5cb4afa39945 (diff)
downloadpatches-36f6ed2c64f74193b45e343630d64b083b98b936.tar
patches-36f6ed2c64f74193b45e343630d64b083b98b936.tar.gz
gnu: Add emacs-fringe-helper.
* gnu/packages/emacs-xyz.scm (emacs-fringe-helper): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c9fbb2929e..b6c7f523a8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2340,6 +2340,34 @@ Stack Overflow, Super User, and other StackExchange sites.")
files and directories.")
(license license:gpl3+)))
+(define-public emacs-fringe-helper
+ (let ((commit "ef4a9c023bae18ec1ddd7265f1f2d6d2e775efdd")
+ (revision "1"))
+ (package
+ (name "emacs-fringe-helper")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nschum/fringe-helper.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ra9rc53l1gvkqank8apasl3r7wz2yfjrcvmfk3wpxhh24ppxv9d"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/nschum/fringe-helper.el")
+ (synopsis "Helper functions for fringe bitmaps")
+ (description
+ "This package allows fringe bitmaps to be defined with a visual string
+representation.")
+ (license license:gpl2+))))
+
(define-public emacs-git-gutter
(package
(name "emacs-git-gutter")