summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <brian@debian>2019-12-03 22:39:01 -0800
committerBrian Leung <brian@debian>2019-12-07 22:16:34 -0800
commite8da79ab6ff8a725e20863ef5d36ff350d5f2791 (patch)
tree3f2864de304b1be6612cd8c49c44ceeec8768cd3
parent20820be9c8c3ad82a6f2cf8c6ef1b1e50e550b90 (diff)
downloadpatches-e8da79ab6ff8a725e20863ef5d36ff350d5f2791.tar
patches-e8da79ab6ff8a725e20863ef5d36ff350d5f2791.tar.gz
gnu: Add emacs-esh-help.
* gnu/packages/emacs-xyz.scm (emacs-esh-help): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8fbc6fde63..f03505b8fa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20321,3 +20321,28 @@ can specify how popup-displaying functions occupy the screen.")
items.")
(home-page "https://github.com/emacs-helm/helm-lacarte")
(license license:gpl3+))))
+
+(define-public emacs-esh-help
+ (let ((commit "417673ed18a983930a66a6692dbfb288a995cb80")
+ (revision "1"))
+ (package
+ (name "emacs-esh-help")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tom-tan/esh-help.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x7d51a6ljl014zy7mi27vzcqqbcwg9z4drq29fr2ajk82mqhlgd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (synopsis "Help functions for Eshell")
+ (description "This package provides a @code{run-help} function inspired
+by @code{zsh} as well as @code{eldoc} support.")
+ (home-page "https://github.com/tom-tan/esh-help")
+ (license license:gpl3+))))