summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-14 18:22:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-14 20:23:21 +0200
commitc3f88d4f345c41220670558391e38af2278936a4 (patch)
tree329306c32e3ea5f81368d26e16ed0529b2e6aafe
parent8aa0d29d3e2f982faa3a7d8ff0ab64bd2073039f (diff)
downloadpatches-c3f88d4f345c41220670558391e38af2278936a4.tar
patches-c3f88d4f345c41220670558391e38af2278936a4.tar.gz
gnu: txr: Declare test target.
* gnu/packages/lisp.scm (txr)[arguments]: Use #:test-target instead of a trivial custom ‘check’ phase.
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 709ea88ae0..b35fa3225a 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -860,6 +860,7 @@ enough to play the original mainframe Zork all the way through.")
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("cc=gcc")
+ #:test-target "tests"
#:phases (modify-phases %standard-phases
(add-after 'configure 'fix-tests
(lambda _
@@ -867,10 +868,7 @@ enough to play the original mainframe Zork all the way through.")
(("/usr/bin") "/"))
(substitute* "tests/017/realpath.expected"
(("/usr/bin") "/"))
- #t))
- (replace 'check
- (lambda _
- (invoke "make" "tests"))))))
+ #t)))))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)))