summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-05 13:00:12 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-09 21:19:47 +0200
commitbcdee2dc336439de5bc90b2712d83ecc865c45d7 (patch)
tree5a93afff57c4acf8140ef117150c92febc7cc584
parent192a59d0f6d7f8f549c0c8225ceef999cff65d31 (diff)
downloadpatches-bcdee2dc336439de5bc90b2712d83ecc865c45d7.tar
patches-bcdee2dc336439de5bc90b2712d83ecc865c45d7.tar.gz
gnu: polkit: Update to 0.115 [fixes CVE-2018-1116].
* gnu/packages/polkit.scm (polkit): Update to 0.115. [origin]: Adjust snippet. [inputs]: Replace mozjs with mozjs-52. * gnu/packages/patches/polkit-drop-test.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it. (cherry picked from commit 50afd712312a4b9fa42d7f9d03464e542b3aeb75) Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/polkit-drop-test.patch18
-rw-r--r--gnu/packages/polkit.scm14
3 files changed, 9 insertions, 24 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 305eed5c30..7b2c7d1ba6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1039,7 +1039,6 @@ dist_patch_DATA = \
%D%/packages/patches/plink-1.07-unclobber-i.patch \
%D%/packages/patches/plink-endian-detection.patch \
%D%/packages/patches/plotutils-libpng-jmpbuf.patch \
- %D%/packages/patches/polkit-drop-test.patch \
%D%/packages/patches/portaudio-audacity-compat.patch \
%D%/packages/patches/portmidi-modular-build.patch \
%D%/packages/patches/potrace-tests.patch \
diff --git a/gnu/packages/patches/polkit-drop-test.patch b/gnu/packages/patches/polkit-drop-test.patch
deleted file mode 100644
index 2fd0c8bdf6..0000000000
--- a/gnu/packages/patches/polkit-drop-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Drop test failing with the following message:
-FAIL: polkitbackendjsauthoritytest
-==================================
-/PolkitBackendJsAuthority/get_admin_identities: Error getting system bus: Could not connect: No such file or directoryError loading /var/run/ConsoleKit/database: Error statting file /var/run/ConsoleKit/database: No such file or directory
-
-
-diff -ru polkit-0.112.old/test/Makefile.in polkit-0.112/test/Makefile.in
---- polkit-0.112.old/test/Makefile.in 2013-07-08 22:52:13.000000000 +0200
-+++ polkit-0.112/test/Makefile.in 2014-11-09 18:43:47.000000000 +0100
-@@ -388,7 +388,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = mocklibc . polkit polkitbackend
-+SUBDIRS = mocklibc . polkit
- AM_CFLAGS = $(GLIB_CFLAGS)
- noinst_LTLIBRARIES = libpolkit-test-helper.la
- libpolkit_test_helper_la_SOURCES = polkittesthelper.c polkittesthelper.h
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a3dbc4ff79..7cc5205faa 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,7 +43,7 @@
(define-public polkit
(package
(name "polkit")
- (version "0.113")
+ (version "0.115")
(source (origin
(method url-fetch)
(uri (string-append
@@ -50,12 +51,15 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "109w86kfqrgz83g9ivggplmgc77rz8kx8646izvm2jb57h4rbh71"))
- (patches (search-patches "polkit-drop-test.patch"))
+ "0c91y61y4gy6p91cwbzg32dhavw4b7fflg370rimqhdxpzdfr1rg"))
(modules '((guix build utils)))
(snippet
'(begin
(use-modules (guix build utils))
+ ;; Disable broken test.
+ (substitute* "test/Makefile.in"
+ (("SUBDIRS = mocklibc . polkit polkitbackend")
+ "SUBDIRS = mocklibc . polkit"))
(substitute* "configure"
;; Replace libsystemd-login with libelogind.
(("libsystemd-login") "libelogind")
@@ -66,7 +70,7 @@
(("systemd") "elogind"))
(substitute* "src/polkitbackend/polkitbackendsessionmonitor-systemd.c"
(("systemd") "elogind"))
- (substitute* "src/polkitbackend/polkitbackendjsauthority.c"
+ (substitute* "src/polkitbackend/polkitbackendjsauthority.cpp"
(("systemd") "elogind"))
;; GuixSD's polkit service stores actions under
@@ -85,7 +89,7 @@
`(("expat" ,expat)
("linux-pam" ,linux-pam)
("elogind" ,elogind)
- ("mozjs" ,mozjs)
+ ("mozjs" ,mozjs-52)
("nspr" ,nspr)))
(propagated-inputs
`(("glib" ,glib))) ; required by polkit-gobject-1.pc