summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-04-08 14:07:59 +0000
committerLudovic Courtès <ludo@gnu.org>2018-04-08 23:32:34 +0200
commit20c902f0d0024a8e8946fc42edc924c0fe3be9d2 (patch)
tree460d8996b24726e9185844dfb6b23bb887da4b9c
parent8cb2bcf7a807177d9beb979d689fe228355b51c0 (diff)
downloadpatches-20c902f0d0024a8e8946fc42edc924c0fe3be9d2.tar
patches-20c902f0d0024a8e8946fc42edc924c0fe3be9d2.tar.gz
gnu: ghc-psqueues: Update to 0.2.6.0.
* gnu/packages/haskell.scm (ghc-psqueues): Update to 0.2.6.0. [arguments]: Enable tests. [home-page]: Update link. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dcb48f34de..9b26ff56f2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7822,7 +7822,7 @@ bytestrings and their hexademical representation.")
(define-public ghc-psqueues
(package
(name "ghc-psqueues")
- (version "0.2.2.3")
+ (version "0.2.6.0")
(source
(origin
(method url-fetch)
@@ -7831,9 +7831,8 @@ bytestrings and their hexademical representation.")
"psqueues-" version ".tar.gz"))
(sha256
(base32
- "1dd6xv1wjxj1xinx155b14hijw8fafrg4096srzdzj7xyqq7qxbd"))))
+ "0n39s1i88j6s7vvsdhpbhcr3gpbwlzabwcc3nbd7nqb4kb4i0sls"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; Tests require QuickCheck < 2.10
(inputs
`(("ghc-hashable" ,ghc-hashable)))
(native-inputs
@@ -7843,7 +7842,7 @@ bytestrings and their hexademical representation.")
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
- (home-page "https://github.com/bttr/psqueues")
+ (home-page "https://github.com/jaspervdj/psqueues")
(synopsis "Pure priority search queues")
(description "The psqueues package provides
@uref{https://en.wikipedia.org/wiki/Priority_queue, Priority Search Queues} in